Résultats de 1 à 9 sur 9

Sujet : encore un probleme

  1. #1

    encore un probleme

    me re voila avec le bug précédant pour la fenetre de dialogue. j\'ai laissé tomber et j\'ai voulu ouvrir une fenetre java avec swing.
    la compilation se passe bien mais il m\'affiche à l\'execution:
    Exception in thread \"main\" java.lang.Error: not implemented
    at javax.swing.UIDefaults.put(java.lang.Object, java.lang.Object) (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.plaf.basic.BasicDefaults.BasicDefaults () (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.plaf.metal.MetalLookAndFeel.getDefault s() (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.UIManager.getDefaults() (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.UIManager.getUI(javax.swing.JComponent ) (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.JPanel.updateUI() (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.JPanel.JPanel(java.awt.LayoutManager, boolean) (/usr/lib/libgcj.so.4.0.0)
    at javax.swing.JPanel.JPanel() (/usr/lib/libgcj.so.4.0.0)
    at essai.main(java.lang.String[]) (Unknown Source)

    **********************************************
    je voudrais aussi préciser que sous linux avec konqueror lors de l\'écriture de message les champs du formulaires sont totalement décalé.
    vérifier votre code, une erreur c\'est glissé et konqueror réagit à la moindre erreur de html et css2.

    sinon le site et pratique et les graphisme ont des couleurs trop flash.

    bon courage pour la suite

  2. #2
    Membre MP
    Inscrit
    août 2013
    Messages
    1 823
    C\'est quoi ce message ?

    je voudrais aussi préciser que sous linux avec konqueror lors de l\'écriture de message les champs du formulaires sont totalement décalé.
    Quel rapport avec le problème ?

    vérifier votre code, une erreur c\'est glissé et konqueror réagit à la moindre erreur de html et css2.
    La pauvre petite biche ce ConError !! si j\'avais le temps je le pleindrai.

    Alors la je comprend RIEN au problème ! Il me semble que ton problème en fait est la suite du precedent sur les boites de dialogue. Alors soit gentil et ne crée pas 50000 Thread les un a la suite des autre.

    Une autre chose, je fais l\'effort de chercher des reponses a ta premières question et toi tu te pointe en disant \'j\'ai laissé tombé\' . Déjà tu devrai le dire sur l\'autre post et ensuite il m\'a falu 3 mn pour faire tourner ton truc que je connaissait pas et toi tu laisse tomber ????

    C\'est sur que si tu te conduit comme cela il va faloir du courage pour la suite !

    Bon en plus il y a trois ou quatre Messages en debut de forum Java dont un concernet l\'usage du forum merci d\'y faire un tour et de les lires.

    Si des fois tu avais une réelle question Reformule.

  3. #3
    desolé pour le message avec konqueror c\'était une remarque pour t\'aider car je fait aussi des site internet et je sais que rendre compatible un site pour tous les navigateurs est très dur deplus je vais tres rarement sur les forums, cela ne m\'interrese pas beaucoup je préfaire les faire enfin quand je dit que je laisse tomber c pas exactement ca c plutot je laisse de coté en attandnat de connaitre d\'avantage le java pour me repencher sur la question

  4. #4
    Visiteur MP
    Visiteur MP
    Salut,
    je pense que tu as oublié de faire un
    import javax.swing.* au début de ta classe, ou alors tu as mal précisé le chemin de ton .jar dans ton classpath.
    A vérifier...

    ++

  5. #5
    Visiteur MP
    Visiteur MP
    mon classpath? je crois que c\'est ca, peux tu m\'expliquer comment le configurer? :

  6. #6
    Visiteur MP
    Visiteur MP
    le probleme n\'est toujours pas partie, c\'est le path de chemin d\'execution qui est mal configuré. :cry:

  7. #7
    Membre MP
    Inscrit
    août 2013
    Messages
    1 823
    Montre plutôt le code qui génère une erreur et la copie de l\'erreur ça sera plus parlant et surement plus rapide.

  8. #8
    Visiteur MP
    Visiteur MP
    Pour la configuration suit ça :

    édite le fichier .profile dans ton répertoire\" home\"
    supposons que tu as installé ton \"jdk\" dans le répertoire /usr/local/jdk1.4
    ajoute ces lignes à la fin de ton fichier .profile, puis enregistre-le, puis re-démarre ta session (ou lance . .profile)

    PATH=$PATH:/usr/local/jdk1.4jdk1.4/bin
    export JAVA_HOME=/usr/local/jdk1.4
    export CLASSPATH=/usr/local/jdk1.4:.

    A toi de rajouter des librairies par la suite si tu en utilise...

    Bon courage,
    ++

  9. #9
    Probleme le fichier /home/.../.profile n\'existe pas! dois-je le créer?

Informations du sujet

Utilisateur(s) parcourant ce sujet

il y a actuellement 1 utilisateur(s) parcourant ce sujet. (0 membre(s) et 1 visiteur(s))

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé