Résultats de 1 à 5 sur 5

Sujet : Arbre-Treeview-Prob. de rafraichissement

  1. #1
    Membre MP
    Inscrit
    août 2013
    Messages
    24

    Arbre-Treeview-Prob. de rafraichissement

    S.O.S. je deviens fou :!:

    A partir de Windev 8, à l\'aide du débugueur j\'obtiens ceci:

    Un treeview vient de se remplir.

    Lorsque je clique pour la 1ère fois sur le symbole + d\'un des éléments de mon treeview, Windev rentre dans la méthode \"Sélection d\'une ligne de Arbre_Toto \" puis rentre à nouveau dans la méthode \"Sélection d\'une ligne de Arbre_Toto \".

    Pourquoi Windev passe-t-il deux fois dans la méthode ? Une seule fois devrait suffir non ?

    Puis quand je clique sur n\'importe quel autre symbole + (ou le même) de mon treeview, Windev ne rentre plus dans la méthode \"Sélection d\'une ligne de Arbre_Toto \". Windev ne rentrera plus dans cette méthode tant que je n\'aurai pas cliqué sur l\'image ou sur le texte d\'une des branches de mon treeview.

    A la suite de quoi, je m\'interroge sur ce comportement un peu particulier et tire, peut-être un peu hativement, la conclusion suivante:

    - soit Windev devrait entrer systématiquement dans la dite méthode lorsque je clique sur le symbole +, soit jamais ! Mais pas \"seulement la 1ère fois que je clique dessus et après plus.


    Merci pour toute réponse, même négative.

    A+

  2. #2
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    Encore moi, j\'ai oublié de préciser:

    Idéalement, il me semble qu\'il ne devrait jamais passer dans cette méthode lorsque je clique sur le symbole +, car dans cette méthode j\'y ai mis le rafraichissement de mon treeview...
    Autrement, ou devrais-je mettre le rafraichissement de mon treeview ? Mon treeview se reconstruit en fonction de ce que sélectionne l\'utilisateur, un peu comme un menu de navigation contextuel.

  3. #3
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    passe tout ce que tu voulais faire dans \"selection d\'une ligne\" dans l\'événement double clique... regarde si ca fait tjrs pareil :wink:

  4. #4
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    Bien vu. Je vais essayer, merci.

  5. #5
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    Effectivement, avec les autres clics ça marche !
    Petit bug de WD... mais un double clic devrait faire l\'affaire
    :cry: :cry: :8O: :lol:

Informations du sujet

Utilisateur(s) parcourant ce sujet

il y a actuellement 1 utilisateur(s) parcourant ce sujet. (0 membre(s) et 1 visiteur(s))

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé