Page 1 sur 2 12 DernièreDernière
Résultats de 1 à 10 sur 11

Sujet : API & Windev

  1. #1
    Membre MP
    Inscrit
    août 2013
    Messages
    4

    API & Windev

    Je cherche a dévelloper une application qui lorsque l\'on clique sur un bouton se réduise dans le traybar (pres de l horloge système).J\'ai trouver un bout de code sur le net malheureusement il ne fonctionne pas entierement.
    La partie \"iconistaion\" marche tres bien mais lorsque je clique sur cette icone je n\'arrive pas a gérer les évènements...

    Cette partie du code fonctionne:
    Code:
    PROCEDURE GereIcone(NomIcone, Mode ,Bulle)
    // NomIcone = Nom du .ICO à utiliser
    // Mode = Action à réaliser
    // 1 - Ajouter = Faire apparaître l\'icône
    // 2 - Modifier = Changer d\'icône
    // 3 - Supprimer = Faire disparaître l\'icône
    // NB : En Ajout ou Modification, on peut choisir la bulle 
    // d\'aide de l\'icône
    // Ce code vous est offert par Beaussier en ligne
    
    hIcon est un entier 
    lpIconName est une chaîne ASCIIZ sur 255
    Res est un entier 
    Cmd est un entier 
    NumEvenement est un entier = 0x8000 + 100
    lpIconName = NomIcone
    NOTIFYICONDATA est une structure
    
    	cbSize est un entier 
    	hWnd est un entier 
    	uID est un entier 
    	uFlags est un entier 
    	uCallback est un entier 
    	hIcon est un entier 
    	szTip est une chaîne ASCIIZ sur 64
    FIN
    
    
    lpData est un NOTIFYICONDATA
    
    // préparation de l\'icône à afficher
    
    SELON Mode
    
    	CAS \"Ajouter\" // Ajout de l\'icône
    		// chargement de l\'icône et récupération de son handle
    		hIcon = AppelDLL32(\"user32\", \"LoadImageA\", Instance(), &lpIconName,1,16,16,16)
    		Cmd = 0 // N° de la commande \"shell_NotifyIconA\"
    
    	CAS \"Modifier\" // Modification de l\'icône
    		// chargement de l\'icône et récupération de son handle
    		hIcon = AppelDLL32(\"user32\",\"LoadImageA\", Instance(), &lpIconName,1,16,16,16)
    		Cmd = 1 // N° de la commande \"shell_NotifyIconA\"
    
    	CAS \"Supprimer\" // Suppression de l\'icône
    		// récupération d\'un handle d\'icône vide
    		hIcon = AppelDLL32(\"user32\", \"LoadIconA\", 0, 32514)
    		Cmd = 2 // N° de la commande \"shell_NotifyIconA\"
    
    FIN 
    
    SI hIcon > 0 ALORS
    	lpData:cbSize = Dimension(lpData)
    	lpData:hICon = hIcon
    	lpData:uID = 100
    	lpData:hWnd = Handle()
    	lpData:uFlags = 7 
    	lpData:szTip = Bulle
    	lpData:uCallback = NumEvenement
    
    	// changement dans la zone d\'icônes de la barre de tâche
    
    	Res = AppelDLL32(\"shell32\", \"Shell_NotifyIconA\", Cmd, &lpData)
    	SI hIcon > 0 ALORS AppelDLL32(\"user32\",\"DestroyIcon\", hIcon)
    
    	
    
    FIN 
    
    SELON Mode
    
    	CAS \"Ajouter\"
    		// Gestion événements icône dans la barre des tâches
    		Res = Evénement(\"TraiteIcone\",\"\", NumEvenement)
    
    	CAS \"Supprimer\"
    		// arrête la gestion des événements associés à l\'icone 
    		//dans la barre des tâches
    		FinEvénement(Res)
    FIN
    C\'est a partir de maintenant que sa se gâte:

    Code:
    PROCEDURE TraiteIcone()
    
    
    // Procédure événementielle détectant toute action faite sur l\'icône
    // On peut déclencher un traitement sur un des événements de l\'icône :
    // Clic gauche (enfoncé / relaché)
    // Clic droit (enfoncé / relaché) 
    // Double-clic (Gauche ou droit)
    // Ce code vous est offert par Beaussier en ligne
    
    SI _EVE.wparam = 100
    
    	SELON _EVE.lparam
    
    		CAS 513
    
    			//Oreille gauche de souris enfoncé sur l\'icône
    
    		CAS 514
    
    			//Oreille gauche de souris relâché sur l\'icône
    
    		CAS 515
    
    			//Double clic oreille gauche sur l\'icône
    				SI FenEtat(FenEnCours()) = Invisible ALORS
    
    				// Activation de l\'application
    				FenEtat(FenEnCours(), Actif) 
    
    			FIN
    
    		CAS 516
    			
    			//Oreille droite souris enfoncé sur l\'icône
    
    		CAS 517
    
    			//Oreille droite souris relâché sur l\'icône
    
    		CAS 518
    
    			//Double clic oreille droite sur l\'icône
    
    	FIN //du SELON
    
    FIN
    Si quelqu\'un a une idée ou des liens interressant pour m aider...
    Merci ++

  2. #2
    Membre MP
    Inscrit
    août 2013
    Messages
    4
    Bon visiblement pas grand mond einspirés :s mais j\'ai trouvé mon bonheur ailleurs, alors pour ceux qui passeront plus tard la meme chose que moi et qui sont intérréssés par la solution pensez a aller voir dans l\'aide la fonction SysIconeAjoute (a moins que vous preferiez les api... )
    ++ all

  3. #3
    Visiteur MP
    Visiteur MP
    c\'est toi jean-paul????

  4. #4
    Membre MP
    Inscrit
    août 2013
    Messages
    4
    Hum je vois que mon pseudo depasse l univers des LAN\'s .
    Toi t ki???

  5. #5
    Membre MP
    Inscrit
    août 2013
    Messages
    204
    j\'avais oublié de me loguer.
    tu m\'as reconnus.
    alors ton stage sa ce passe bien.
    moi je doit developper un trucs en JAVA.
    alors vas-y apprend le JAVA, fait toi mal
    bon fallait bien l\'apprendre un jour, alors bon..
    "Use Soap"

  6. #6
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    Et bien personnellement, je trouve Windev très bien pour apprendre à programmer, mais si on veut véritablement maitriser son code, il vaut mieux le faire en JAVA, parce que lorsqu\'on rencontre un problème sur Windev, si celui-ci est inhérent au produit, alors bonne chance pour le détecter et c\'est très difficile de le contourner... :cry: :cry: :x: :evil:

  7. #7
    Membre MP
    Inscrit
    août 2013
    Messages
    204
    disons que Windev est ce que Visual Basic est a la programmation :
    non je deconne.
    en tous cas sur Java le debut est pas facile.
    je pense que c\'est son coté orienté objet qui fait sa....
    "Use Soap"

  8. #8
    Membre MP
    Inscrit
    août 2013
    Messages
    204
    au fait popof.
    c\'étais pour quelle appli que tu cherche sa?

    sinon, si tu est sur ce forum, c\'est que sa doit etre un bon forum..... :
    moi pour trouver un bon forum sur la programmation je vais sur google et je tappe:
    \"forum+popof\"
    : : :
    "Use Soap"

  9. #9
    Membre MP
    Inscrit
    août 2013
    Messages
    24
    Est-ce que Popof est également Popov2 des rampants ?

  10. #10
    Membre MP
    Inscrit
    août 2013
    Messages
    204
    je ne crois pas il n\'a qu\'1 pseudo qui est POPOF.
    c\'est un gros joueur je Quake, c\'est pour ddcela qu\'il parler des LAN\'s.
    "Use Soap"

Page 1 sur 2 12 DernièreDernière

Informations du sujet

Utilisateur(s) parcourant ce sujet

il y a actuellement 1 utilisateur(s) parcourant ce sujet. (0 membre(s) et 1 visiteur(s))

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé