Résultats de 1 à 5 sur 5

Sujet : Aide Fmod struct FSOUND_STREAM *

  1. #1

    Aide Fmod struct FSOUND_STREAM *

    salut à tous, voila j\'ai un pti pb avec l\'utilisation de fmod... je pense que c tt con ms je trouve pas. car je dvlp un jeu un gtk, C++ et fmod mais le truc c que j\'ai des erreurs du genre :

    [-i]error C2065: \'FSOUND_Stream_OpenFile\' : undeclared identifier[/i] ou
    [-i]\'initializing\' : cannot convert from \'int\' to \'struct FSOUND_STREAM *\'[/i]

    je suis sous visual 6
    A bon entendeur....

    -----------------------------------

    \"En info, le pb se situe souvent entre la chaise et l\'ordinateur!\"
    L\'alcool est la cause et le remède à tous nos problèmes! Homer Simpsons

  2. #2
    Membre MP
    Inscrit
    août 2013
    Messages
    665
    Est ce que tu as inclus les librairies (des fichiers en .lib), c\'est con comme question mais il vaut mieux commencer par le plus simple pour ne pas blablater pour rien. :roll:
    [col=#FFDD1A]( [/col][col=#FF0000]B[/col]e [col=#FF0000]S[/col]i[col=#FF0000]d[/col]e [col=#FFDD1A])[/col]

  3. #3
    Membre MP
    Inscrit
    août 2013
    Messages
    329
    Si tu as que ça comme erreur vérifies le proto de FSoundOpenStream par rapport au fichier fmod.h :

  4. #4
    merci pour tout vos pti conseils, j\'ai pu réparer car en faitil me manquait 2 arguments ds une fonction alors que pourtant il mettait ds la doc fmod qu\'ils étaient facultatifs...
    mais , car il y a toujours un mais en prog,
    j\'ai un autre erreur mais pas a la compilation mais à l\'execution :

    [-i]Le point d\'entrée de procédure _FSOUND_Sample_Load@20 est introuvable dans la bibliothèque de liaision dynamique fmod.dll[/i]
    :?:

    et là, je vois pas...
    L\'alcool est la cause et le remède à tous nos problèmes! Homer Simpsons

  5. #5
    Membre MP
    Inscrit
    août 2013
    Messages
    2
    ton probleme c\'est du a ton fmod.dll il est trop vieux, tu dois en telecharger un qui fait environ 255K je crois, en tout cas c\'est celui que j\'utilise mais en revanche moi j\'ai un probleme qui apparait par la suite, il parait que c\'est du au compilateur visual.net donc si t\'arrive a le faire marcher tiens moi au courant stp

Informations du sujet

Utilisateur(s) parcourant ce sujet

il y a actuellement 1 utilisateur(s) parcourant ce sujet. (0 membre(s) et 1 visiteur(s))

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas éditer vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé